vipw lockfile (/etc/ptmp) is present. [2012-06-08 03:24:09 -0400] warn [whostmgr5] Attempt to repair system password files because we received an error while adding a user: signal=[0] code=[1]. at /usr/local/cpanel/Cpanel/SysAccounts.pm line 180

ARUN Post in WHM BACKEND, WHM FRONTEND
0

Getting the below error in cpanel error logs   /usr/local/cpanel/logs/error_log when we try to create a new account :

vipw lockfile (/etc/ptmp) is present. [2012-06-08 03:24:09 -0400] warn [whostmgr5] Attempt to repair system password files because we received an error while adding a user: signal=[0] code=[1]. at /usr/local/cpanel/Cpanel/SysAccounts.pm line 180

Solution :

Remove the file named  /etc/ptmp and try to create the account.

/usr/local/cpanel/logs/error_log

/ getting filled up

ARUN Post in DISK RELATED
0

du -sch /root/.cpanel/comet/channels

Remove files like  “%2fpurge_mail_queue%2fCypl11rGti4q1i6t”

Clear all the emails from mail queue

You can login to WHM >> Mail Queue to do this

or

”  exim -bp | awk ‘/^ *[0-9]+[mhd]/{print “exim -Mrm ” $3}’ | bash   ”

 

 

Yum log file path

ARUN Post in FILE PATH ( conf, logs etc), LOG FILES, YUM
0

/var/log/yum.log

-bash: smartctl: command not found

ARUN Post in DISK RELATED
0

yum install smartmontools

How to install cpanel dnsonly

ARUN Post in WHM BACKEND
0
Installing cPanel DNSONLY
 
cd /home 
wget -N http://httpupdate.cpanel.net/latest-dnsonly
sh latest-dnsonly

How to restrict root access to server using IP address

ARUN Post in SSH
0

vi /etc/security/access.conf

Scroll down to bottom and add

========================

-:root:ALL EXCEPT   IP_ADDRESS 1      IP_ADDRESS2 

========================

You can also try :

vi /etc/security/access.conf

========================

- : ALL : ALL EXCEPT  IP_ADDRESS 1      IP_ADDRESS2

========================

ssh_exchange_identification: Connection closed by remote host

ARUN Post in SSH
0

Check if the host file has any conflicting entries.

cat /etc/hosts.deny

cat /etc/hosts.allow

How to restrict ssh access to certain IP address.

ARUN Post in SSH
0

vi /etc/hosts.allow

SSHD:   IP_ADDRESS    #Acenet

 vi /etc/hosts.deny

sshd: ALL

 

Joomla admin page comes out without the login prompt

ARUN Post in JOOMLA
0

After a update joomla admin page comes out without the login prompt, however I can see the logout button when I try accessing the login screen

www.domain.com/administrator.

Solution :

Open helper.php   under  /home/UN/public_html/administrator/includes/

change line 30 :    if (!$user->authorise(‘core.login.admin’)) {

to

if ($user->get(‘guest’)) {

Save and quit

How to change ulimit for user

ARUN Post in Operating System
0

vi /etc/security/limits.conf

scroll to the bottom

Now to change the memory limit use

=====================

arun hard rss unlimited

=====================

Logs to see if the email is created/deleted in cpanel server

ARUN Post in LOG ANALYSIS, LOG FILES, MAIL, WHM BACKEND
0

[email protected] [/usr/local/cpanel/logs]# grep mytest ./access_log | grep addpop
208.46.180.9 – arunp [05/17/2012:04:57:57 -0000] “GET /cpsess4756242303/json-api/cpanel?cpanel_jsonapi_version=2&cpanel_jsonapi_module=Email&cpanel_jsonapi_func=addpop&email=mytest&password=__HIDDEN__&quota=250&domain=arunp.in&cache_fix=1337230678750 HTTP/1.1″ 200 0 “http://72.44.91.97:2082/cpsess4756242303/frontend/x3/mail/pops.html” “Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.168 Safari/535.19″
[email protected] [/usr/local/cpanel/logs]#

 

[email protected] [/usr/local/cpanel/logs]# grep mytest ./access_log | grep delpop
208.46.180.9 – arunp [05/17/2012:05:01:00 -0000] “GET /cpsess4756242303/json-api/cpanel?cpanel_jsonapi_version=2&cpanel_jsonapi_module=Email&cpanel_jsonapi_func=delpop&email=mytest&domain=arunp.in&cache_fix=1337230862987 HTTP/1.1″ 200 0 “http://72.44.91.97:2082/cpsess4756242303/frontend/x3/mail/pops.html” “Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.168 Safari/535.19″
[email protected] [/usr/local/cpanel/logs]#

HTTP output character conversion is improperly configured mbstring.http_output must be set to pass. You can check the current value on the PHP information page.

ARUN Post in ERROR
0

Error in phpbb admin page as mentioned below :

HTTP output character conversion is improperly configured  mbstring.http_output must be set to pass. You can check the current value on the PHP information page.

Solution :

First try with php.ini and .htaccess

==================

mbstring.http_input = pass
mbstring.http_output = pass

==================

If that wont work open the config.php file and add the below line under “<?php”

++++++++++++++++++++++++++++++++++++++

ini_set(“mbstring.http_input”, “pass”);
ini_set(“mbstring.http_output”, “pass”);

++++++++++++++++++++++++++++++++++++++

HTTP input character conversion is improperly configured mbstring.http_input must be set to pass. You can check the current value on the PHP information page.

ARUN Post in ERROR
0

Error in phpbb admin page as mentioned below :

HTTP input character conversion is improperly configured  mbstring.http_input must be set to pass. You can check the current value on the PHP information page.

Solution :

First try with php.ini and .htaccess

==================

mbstring.http_input = pass
mbstring.http_output = pass

==================

If that wont work open the config.php file and add the below line under “<?php”

++++++++++++++++++++++++++++++++++++++

ini_set(“mbstring.http_input”, “pass”);
ini_set(“mbstring.http_output”, “pass”);

++++++++++++++++++++++++++++++++++++++

 

How to increase the number of files viewable through FTP

ARUN Post in FTP
0

Edit  pure-ftpd.conf

vi /etc/pure-ftpd.conf

and change the value of the below field.

LimitRecursion

Remember to restart FTP service

warning: date() [function.date]: It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function.

ARUN Post in PHP
0

warning: date() [function.date]: It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function.

Solution :

Open the appropriate file that is giving the error

On top before the first function add :

date_default_timezone_set(‘UTC’);

date_default_timezone_set(‘America/Los_Angeles’);

date.timezone=”America/New_York”   — > works