Error ” Error from park wrapper “

ARUN Posted in WHM BACKEND
0

While Adding addon domain we get the error

” Error from park wrapper: domain.com is already configured. ”

Solution :

grep USERNAME /etc/ -irl

OR

Remove the entry for the domain from the following files :

/var/cpanel/users/username
/scripts/updateuserdomains
/var/named/domain.db
/etc/named.conf
/usr/local/apache/conf/httpd.conf
/etc/localdomains
/etc/userdomains
/etc/trueuserdomains
/etc/trueuserowners
/etc/valiases/domain.com
/etc/vdomainaliases/domain.com
/etc/vfilters/domain.com

Disable su user in WHM server and enable direct root login

ARUN Posted in WHM BACKEND, WHM FRONTEND
0

Login to WHM as root and put the below in browser and hit Enter

IP:2086/scripts2/doautofixer?autofix=safesshrestart

set upcp stable, release

ARUN Posted in WHM BACKEND
0

vi /etc/cpupdate.conf

Or

Login to WHM >> Update Preferences >> Select ” Automatic (STABLE tree) ”

Click save

CPanel Installation

ARUN Posted in INSTALLATION, WHM BACKEND
0

To begin your installation, use the following commands:

  1. cd /home — Opens the directory /home.
  2. wget -N http://layer1.cpanel.net/latest — Fetches the latest installation file from the cPanel servers.
  3. NEW :   wget http://httpupdate.cpanel.net/latest
  4. sh latest — Opens and runs the installation files.
  5. /usr/local/cpanel/cpkeyclt — Activates your license after installation.

Set max emails per hour for a particular domain

ARUN Posted in WHM BACKEND
0

vi /var/cpanel/maxemails

webhostingdevelopment.com=20000

Then run the command

/scripts/build_maxemails_config

This will create a file  :   /var/cpanel/maxemailsperdomain/webhostingdevelopment.com

To verify if the emails per hour is set use :

cat /var/cpanel/maxemailsperdomain/webhostingdevelopment.com

IN NEW CPANEL 11.32 USE

vi /var/cpanel/users/USER_NAME  to change this value

MAX_EMAIL_PER_HOUR=1500

After editing the file run the below commands as well :

/usr/local/cpanel/scripts/update_email_limits USER_NAME

/usr/local/cpanel/scripts/updateuserdomains

syslogd shows failed in WHM but actually not

ARUN Posted in WHM BACKEND
0

WHM >> Service status shows that ” syslogd ” is stopped. But While we login to server and check the status is up

service rsyslog status

** Try restarting syslogd **

/scripts/restartsrv syslogd

/etc/init.d/rsyslog restart

** Try restarting chkservd **

/scripts/restartsrv chkservd

service chkservd restart

Still if it dont show its up, try running a upcp both in release and stable versions.

Webmail password wont work.

ARUN Posted in WHM BACKEND
0

Reset password wont work and so changing password manually.

cd /home/username/etc/domainname/

vi shadow

&

vi passwd

Make sure that the entries are present.

View files in server using IP in WHM server

ARUN Posted in WHM BACKEND
0

cd /usr/local/apache/htdocs/

Put any file inside this folder and you can access that through IP/filename

Cpanel liscence file error

ARUN Posted in WHM BACKEND
0
  1. First, go to http://verify.cpanel.net/ and enter the public IP address of this server to make sure it is licensed.
  2. If licensed, try running /usr/local/cpanel/cpkeyclt from the command line as root.

Manually generate stats

ARUN Posted in WHM BACKEND
0

/scripts/runweblogs UN

Service check file in cpanel

ARUN Posted in WHM BACKEND
0

vi /etc/chkserv.d/chkservd.conf

exim:1  –> Service will be checked.

exim:0  –> Service will not be checked.

FIND A DOMAIN IN WHM SERVER

ARUN Posted in WHM BACKEND
0

cat /etc/userdomains | grep domain name            –> shows the username and the domain name

cat /etc/trueuserdomains | grep username

cat /var/cpanel/accounting.log | grep globus-imenik.co.yu  —> Shows all accounts-suspended,terminated,etc.



Cannot change password for cpanel a/c`s in WHM

ARUN Posted in WHM BACKEND, WHM FRONTEND
0

While trying to change the cpanel passwords we get the message

“The password for ‘user name’ could not be changed because: ” and that’s it.

SOLUTION

Upgraded cPanel to a stable version and it fixed

Login to WHM >> Update Preferences >> Select ” Automatic (STABLE tree) ”

Click save

Then run the below command in screen

/scripts/upcp –force

Cpanel httpd.conf file path

ARUN Posted in FILE PATH ( conf, logs etc), WHM BACKEND
0

vi /usr/local/apache/conf/httpd.conf